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1 Applicability of Form 10BB and Form 10B and purpose of Webinar

2 Process of filing Form 10BB for A.Y 2023-24

4 Questions & Answers

3 Process of filing Form 10B for A.Y 2023-24

Note : For the purpose of this Webinar “Auditee” means any fund or institution or trust or any university or other
educational institution or any hospital or other medical institution referred to in sub - clause (iv), (v), (vi) or (via) of
clause (23C) of section 10 of the Act or any trust or institution referred to in sections 11 or 12 of the Act.



Applicability of Form 10B and Form 10BB (Rule 16CC and Rule 17B of IT 

Rules)

A.Y. 2023-24 onwards Up-to A.Y. 2022-23

Vide Notification No. 7/2023 dated 21st February 2023

Form No. 10B is applicable where—

1) The total income of auditee, without giving effect to the provisions of 
mentioned clauses/sections, as applicable-

(a) sub-clauses (iv), (v), (vi) and (via) of clause 23C of section 10 

(b) Sections 11 and 12 of the Act, 

exceeds rupees five crores during the previous year; or

2) Auditee has received any foreign contribution during the previous year; or
3) Auditee has applied any part of its income outside India during the previous 

year;

Form No. 10BB in other cases

Up-to A.Y. 2022-23, Audit report in Form
10B was required to be furnished by
Charitable or Religious Institutions
registered under section 12AB.

Form 10BB was required to be furnished
under by funds, trusts and institutions
registered under different clauses of
section 10(23C) of Income Tax Act, 1961.



The purpose of the Webinar is to discuss and understand:

• The step-by-step process of filing Form 10BB in online and offline mode and Form 10B through offline 
utility for AY 2023-24

• The best practices for filing the forms

• Address grievances and provide resolutions for smooth filing of Form 10B and Form 10BB 

Purpose of the Webinar

Please note that the due date of filing Form 10B and Form 10BB for A.Y. 2023-24 has been
extended to 31st October, 2023 as per Circular No. 16/2023 dated 18th September 2023.
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Pre-requisites for filing the Forms

• Auditee and CA is registered at e-filing portal.

• They have valid Username and Password.

• CA should have a valid DSC registered at e-filing portal & not expired.

• Auditee should have a valid DSC (if applicable) or EVC. 

• Auditee should assign the Form to CA along with necessary documents.
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Important Points to be Noted

• It has been noticed that some audit reports have been submitted in old Form 10B or Form 10BB for AY 

2023-24, which cannot be considered as valid in view of amendments made in Rule 16CC and Rule 17B of 

Income Tax Rules. To ensure compliance and to avoid any legal implications, such taxpayers are requested 

to file re-notified Form 10B or 10BB, as applicable in case of auditee for A.Y. 2023-24.

• These re-notified Forms 10B and 10BB are available on e-Filing portal with names-

• Form 10B (A.Y. 2023-24 onwards)

• Form 10BB (A.Y. 2023-24 onwards)

• Please note that only one audit form either 10B or 10BB is applicable on the auditee. Please refer Rule 

16CC and Rule 17B of Income Tax Rules,1962 to check the applicability.



7

Process Flow

Step-1: Adding CA by Auditee

If CA is already added, skip to Step 2. 

Step-2: by Auditee

Assign Relevant Form either through My CA Functionality or File Forms 

Functionality to CA. 

Step-3: by CA

Accept the Request under CA 

Login. 

Step-4: by CA

Upload Form under CA Login.

Step-5: by CA

Prepare and File Form, upload json (wherever 

applicable) and submit using DSC 

under CA Login. 

Step-6: by Auditee

Accept the Form and complete the process of e-

verification under Auditee Login.

Step-7: by CA/Auditee

The submitted Form can be 

downloaded from View Filed Forms 

Functionality for both CA and 

Auditee Login 



Process of filing Form 10BB for A.Y 2023-24 
onwards in online mode and offline mode



After login to e-filing portal, on Auditee Dashboard, click e-File > Income Tax Forms > File Income Tax 
Forms.
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On screen for selection of Form, select Form 10BB (AY 2023-24 onwards), under the relevant 
section.

28-10-2023 10Note: Carefully select Form 10BB (A.Y. 2023-24 onwards) for filing for A.Y. 2023-24 and Form 10BB for A.Ys. prior to A.Y. 2023-24 
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How to assign Form to CA?



PAN will be pre-filled. Select relevant  Filing Type, AY for which filing is to be done, Assign CA, then 
click Continue.
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Note:

1. If a CA is assigned by you already, details of Form  pending with CA for filing or acceptance will be displayed

2. If CA is not assigned, you can assign a CA by choosing from the existing list of previously assigned CAs from the dropdown menu

3. In case there are no CAs added, you can add a CA by clicking Authorized Partner on Dashboard > Authorized Partners > My CA > Add new CA.



Alternatively, you can add a CA by clicking Authorized Partner

On Dashboard > Authorized Partners > My CA > Add new CA>Enter Membership no.>Click Add and click Confirm.

.

Now, Request for Adding CA has been submitted successfully



Once the CA is added, the Form can also be assigned to CA by clicking on Assign Form in My CA functionality.

.
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On assignment of CA, a success message is displayed along with a Transaction ID. 

Please keep a note of the Transaction ID for future reference.



Form 10BB (A.Y. 2023-24 onwards) – Filing by CA
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Login to the e-filing portal with CA user ID and password.
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On CA’s Dashboard, click Pending Actions > Worklist where list of pending items is displayed.
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Under the For your Action tab, click Accept against the form 10BB which has been assigned by Auditee.
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On acceptance by CA, a success message is displayed along with a Transaction ID. Please keep a note 
of the Transaction ID for future reference. Click on Back to Worklist.
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On the CA login, under the Pending for Filing tab, click Upload Form against the  Form 10BB.
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Select Online/Offline mode and click Continue.

Process of Downloading Offline Utility for Re-notified form 10BB 

Visit https:/ / www.incometax. gov.in ----- > Go to download section---- --> Income tax forms------> Form 10BB (A.Y.2023-24 onwards) -----> 

click on form utility
Note: Please make sure you always use the latest version of utility, available on E-filling portal to download and upload the json.
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Click Let’s Get Started to proceed. 

Please Note - Enabling of Schedules is dependent on selection of Yes/No option in the associated field of the form. Enabling of 

some schedules is also dependent on the amount filled in the associated fields of the form. If any amount more than 0 is 

filled, then then it is mandatory to provide details in that Schedule.



Fill the Form and confirm all the Tabs.



Once the Form is prepared, it needs to be e-verified by CA.

28-10-2023 25



Modes of Verification of Form 10BB (A.Y. 2023-24 onwards)
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• For CAs, only DSC option is available for uploading of Form 10BB.
• For taxpayers (auditee) other than companies, both DSC and EVC options are available to accept the 

form uploaded by CA.
• For Companies, only DSC option is available to accept the form uploaded by CA.
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When the Form is submitted by the CA, the Auditee will also receive a confirmation message on the email ID and mobile number registered with the 

e-Filing portal.

After successful e-Verification, a success message of submission by CA is displayed along with a 
Transaction ID. Please keep a note of the Transaction ID for future reference.
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Return to Auditee’s Dashboard, click Pending Actions > Worklist
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On Auditee’s worklist, under the Pending for Acceptance, click Accept against the Form uploaded by CA.
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Note:

Refer to the How  to e-Verify user manual to learn more. 

On accepting the request, Auditee will be taken to the e-Verify page, e-verify the Form.
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Form 10BB (A.Y. 2023-24 onwards)– Form Submitted.

Note: After successful e-Verification, a success message is displayed along with a Transaction ID and Acknowledgement Receipt Number. Please 
keep a note of the Transaction ID and Acknowledgement Receipt Number for future reference. You will also receive a confirmation message on 
your email ID and mobile number registered with the e-Filing portal.



Resolution of Grievances on Form 10BB
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How can I download the offline utility of Form 10BB 

(A.Y. 2023-24 onwards)? 

Auditee Visit  Home | Income Tax Department -----> Go to Downloads------> Income Tax Forms------> Form 

10BB (A.Y.2023-24 Onwards) -----> Form Utility.

Alternatively, CA can access this path by clicking on Download button under offline filing option at the time of 

uploading form.

Note: Please make sure you always use the latest version of utility available on E-filing portal.
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Can Form 10BB (A.Y. 2023-24 onwards) be filed through ERIs i.e. third 

party softwares?

Yes, this form can be filed through ERIs also using “Offline” filing mode.
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Whether Form 10BB is required to be filed if my income is below basic 

exemption limit?

Please refer to the relevant provisions of clause (b) of the tenth proviso to clause (23C) of section 10 and

sub-clause (ii) of clause (b) of section 12A(1) of the Income Tax Act, 1961 read along with Rule 16CC and Rule

17B of the Income Tax Rules, 1962 for applicability of Form 10BB.
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In Form 10BB, under Report of Accountant Panel, there is no option to select "Society/ 

Company/Non Profit organisation/etc.” Which option shall I choose?

Form 10BB gives following options for selection for auditee detail under "Report from an accountant" panel-

fund, trust, institution, university, other educational institution, hospital or other medical institution.

You may choose the one which is suitable in case of auditee basis the type of organisation for which

provisional/ final registration was granted or according to the nature of activities carried on by organisation

or any other relevant factor that may be taken as basis.
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I am getting error for ‘submission failure’, what should I do?

Please ensure that the profile of Taxpayer and Chartered Accountant is complete for all mandatory fields

including Key person details. Post completion, delete the old draft and re-try filing of fresh form.
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Whether details of specified person as referred to in section 13(3) are mandatory to be provided 

in Sl. No. 28 of Form 10BB, even in case if conditions/criteria mentioned in clause (c) of sub-

section (1) or sub-section (2) of Section 13 are not applicable?

Details of specified persons required in Sl. No. 28 are mandatory to be provided. You may further refer to

Circular No. 17/2023 dated 9th October 2023 and the details of the persons as available may be provided.
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How to generate UDIN for Form 10BB for A.Y. 2023-24? 

Please note that for re-notified Form 10BB, applicable from A.Y. 2023-24 onwards, UDIN needs to be

generated by selecting Form name "Form 10BB- Tenth proviso to section 10(23C)(b)(iv)/(v)/(vi)/(via) and

section 12A(1)(b)(ii)" on UDIN portal.



Process of filing Form 10B for A.Y 2023-24 
onwards in offline mode



Login to e-filing portal, On Auditee’s Dashboard, click e-File > Income Tax Forms > File Income Tax 
Forms.
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On screen for selection of Form, select Form 10B (AY 2023-24 onwards), under the relevant 
section.

28-10-2023 42Note: Carefully select Form 10B (A.Y. 2023-24 onwards) for filing for A.Y. 2023-24 and Form 10B for A.Ys. prior to A.Y. 2023-24 
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The Form can be assigned to CA in the manner like Form 10BB



PAN will be pre-filled. Select relevant  Filing Type, AY for which filing is to be done, Assign CA, 
then click Continue.
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On CA’s Dashboard, click Pending Actions > Worklist where list of pending items is displayed
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Under the For your Action tab, click Accept against the form 10B which has been assigned by Auditee
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On acceptance by CA, a success message is displayed along with a Transaction ID. Please keep a note 
of the Transaction ID for future reference. Click on Back to Worklist.
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On the CA login, click Upload Form against the form 10B



Form 10B (A.Y. 2023-24 onwards) – Preparation of Form by CA



Download the Offline Utility. Fill the form using the utility and create a JSON file. Upload the JSON file
created using the Offline Utility. Attach necessary supporting documents (Balance Sheet, P&L

Account etc.) Click Submit.



Alternatively, Go to Downloads section of e-filing portal and download the Form 10B(AY 2023-24
onwards) offline utility.



Download the latest version of the Utility from Downloads section of e-filing portal and run the 
application from the Downloads section of your computer.



Open the  Form in the Utility and click on File now
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Import the JSON file or Continue without Pre-fill. Click Continue to proceed 
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Attach the file to Import the Pre-fill data
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Once the file is imported, Click Continue
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Check the basic details and click on File Form
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Check the list of Documents required and Click Let’s Get Started
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Download and Read the Instructions. Provide details and confirm each section.
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Details in S. No 6 (Other addresses, if applicable), is required to be provided. In case same is not 
applicable you can provide the same address as provided in registered address.
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Please Note: Enabling of Schedules is dependent on selection of Yes/No option in the other field of the form. Enabling of some schedules also depend 

on the amount filled in the other fields of the form, if any amount more than 0 is filled, then then it is mandatory to provide details in Schedule.



Please Note : A valid json can be download and uploaded only when the status of all the panels is “completed”.



Once the Form is prepared in Json , it is uploaded by CA, click Upload Form to proceed.
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Form 10B (A.Y. 2023-24 onwards)– Once the json is uploaded, the form is e-verified and 
submitted by CA

28-10-2023 64The Auditee will also receive a confirmation message on the email ID and mobile number registered with the e-Filing portal.



Form 10B (A.Y. 2023-24 onwards)– Login by Auditee
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Form 10B (A.Y. 2023-24 onwards)– Acceptance by Auditee
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Note: Refer to the How to e-Verify user manual to learn more. 

On accepting the request, you will be taken to the e-Verify page, e-verify using Digital Signature 
Certificate or through EVC. 



Form 10B (A.Y. 2023-24 onwards) – Submission by Auditee
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Note: After successful e-Verification, a success message is displayed along with a Transaction ID and Acknowledgement Receipt 

Number. Please keep a note of the Transaction ID and Acknowledgement Receipt Number for future reference. You will also receive a 

confirmation message on your email ID and mobile number registered with the e-Filing portal.



Filing of Form 10B (A.Y. 2023-24 onwards) & Form 10BB (A.Y. 2023-24 onwards)– Some Do’s and 
Don’ts
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In order to avoid errors in form filing and verification, kindly ensure

• To use the latest version of the utility for generating JSON

• Ensure that the

✓ PAN of Auditee

✓ Assessment Year

✓ CA Membership Number

✓ Form Filing Type

• Install the latest Emsigner/Embridge application (Version - 5.9.1.0) in your system

• Log in the DSC token

• Profile and contact details are updated in Auditee and CA login

• Check Local Host e-Mudhra is not blacklisted by the system Admin



Resolution of Grievances on Form 10B
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Whether to file Form 10B even if my income is not exceeding the 

maximum amount which is not chargeable to tax?

Please refer to the relevant provisions of clause (b) of the tenth proviso to clause (23C) of section 10 and sub

clause (ii) of clause (b) of section 12A(1) of the Income Tax Act, 1961 read along with Rule 16CC and Rule 17B

of the Income Tax Rules, 1962 for applicability of Form 10B.
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While filing the form 10B, I am getting errors like submission failed OR "Please fix the following issues and try 

submit again: Invalid format for Full name, Invalid Flag, Invalid input, please enter a valid percentage, Invalid flat, 

Invalid Address, Line, Please enter valid PIN code." etc. How to resolve such kind of issues? 

Before initiating the filing, you may ensure the following steps that will helps you in successful submission of form,

1. Profile of the CA and taxpayer should be updated with all mandatory details.

2. Key person details should be updated, if applicable.

3. JSON shall be download from the utility without any error in the JSON.

4. Always use the latest utility available in the download section to generate and upload the valid JSON on the e-Filing 

portal.
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Whether the details of specified persons as referred In Section 13(3) of Income Tax Act,1961 is 

mandatory to provide in S.no 41 of the Form 10B even if there is no transactions year with such 

specified persons during the previous?

Details of specified persons required in SI.No. 41 are mandatory to be provided. You may further refer to circular No. 

17/2023 dated 9th October 2023 and the details if the persons as available may be provided.
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How to generate UDIN for Form 10B for A.Y. 2023-24?

For re-notified Form 10B, applicable from A.Y. 2023-24 onwards, UDIN can be generated by selecting Form name "Form 

10B- Tenth proviso to section 10(23C)(b)(iv)/(v)/(vi)/(via) and section 12A(1)(b)(ii)" on UDIN portal.
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Whether the re-notified form 10B can be filed through a third party 

software?

Yes, Form re-notified form 10B can be filed using third party software.
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What are electronic modes of transaction that are referred in the form?

As referred in rule 6ABBA of the Income-tax Rules, 1962, Electronic modes shall be the following modes:

(a) Credit Card,

(b) Debit Card,

(c) Net Banking,

(d) IMPS (Immediate Payment Service)

(e) UPI (Unified Payment Interface),

(f) RTGS (Real Time Gross Settlement),

(g) NEFT (National Electronic Funds Transfer),

(h) BHIM (Bharat Interface for Money) Aadhar Pay.



Common Instructions to fill schedules and CSVs
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How to attach csv file Download Excel template →Add Records →Convert Excel template into 

.csv file →upload .csv file

In case auditor has more than 50 

rows to fill in schedule

• For number of records upto 50: Either table or CSV option can be used. 

• For number of records more than 50: Only CSV option can be used

Instructions in headers to fill excel 

templates

Instructions headers are provided in each excel templates to assist 

auditor in filling out data in excel.

Dropdown values in the Excel 

templates

Wherever dropdown values are given to choose in the excel templates, 

Auditor is required to select the values from the dropdown itself.

Auto calculated fields in the excel 

templates

Value/amount in auto calculated fields shall be auto calculated by the 

system, do not manually change the value, it may fail to attach your csv 

file in the utility.
Attachment of new csv file If a new CSV file is attached over the old CSV file, it will completely 

replace the old CSV file.



Miscellaneous things to be taken care in filing the offline utility
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Please make sure you are using latest utility available on Income tax site to download and upload the valid JSON.

Denomination of currency of the amount All amount field in the utility shall be in the denomination of Indian rupees only.

Date format Standard date format i.e. DD-MMM-YYYY is required to be followed in the form, for example date can be enter as 

06-MAR-1990.

Nil Value of amount In case of Nil value, auditor can enter 0 as the amount fields are mandatory to be filled.

Filling out the schedule’s panels Below mentioned 5 panels, which require information of different schedules, shall be available only when auditor 

completes the other panels of the utility.

1. Sch. Corpus-DI

2. Sch. DA- Sch. ACA

3. Sch. SP-a -Sch H

4. Sch. TDS disallowable -Sch. Interest on TDS/TCS

5. Sch.269SS- Sch. Other law violation
Download JSON facility without 

completing all panels of the form

Auditor is allowed to download the JSON file even if all the panels are not completed. However, to download and 

upload the valid JSON on e-filling portal, auditor is required to complete all the panels.

Details to be added in table only For the below schedules, auditor is required to add the details in table only i.e. upload csv option is not available for 

these schedules:

1. Schedule corpus

2. Schedule FC

3. Schedule DI

4. Schedule DA

5. Schedule AC

6. Schedule ACA
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Grievance Handling

Email Address: efilingwebmanager@incometax.gov.in

To share your queries on helpdesk email id, kindly provide the following details:
1. Mention the Grievance ID if the grievance is already raised earlier
2. Name and Contact details of the person who can explain the problem
3. PAN of the Auditee
4. User ID at e-filing portal of Chartered Accountant
5. AY
6. Mention Form No. 10B or Form No. 10BB
7. Details of Problem 
8. Attach screenshots
9. Attach JSON if relevant
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For Further Details

Kindly refer to FAQs available in the Help>All Topics> Statutory Forms Section on e-filing portal as under:

Form 10B (A.Y. 2023-24 onwards) FAQs | Income Tax Department

Form 10BB (A.Y. 2023-24 onwards) FAQs | Income Tax Department

https://www.incometax.gov.in/iec/foportal/help/all-topics/statutory-forms/popular-form/form-10B-faq
https://www.incometax.gov.in/iec/foportal/help/all-topics/statutory-forms/popular-form/form-10BB-faq
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We request you to share your questions by mentioning
your name, mobile no., email id, PAN where issue faced.

Contact details of Helpdesk is as under:
1800 103 0025 (or)

1800 419 0025
+91-80-46122000
+91-80-61464700

The Presentation of webinar is over


